【V3/V4】RDP 客户端闪退问题解决思路(Razor)


飞致云 发布于 2024-11-13 / 12 阅读 / 0 评论 /
一、开启或关闭目标 Windows 资产的 NLA 设置 操作方式一: 1、打开运行。 2、运行中输入 sysdm.cpl ,点击确定。

一、开启或关闭目标 Windows 资产的 NLA 设置

操作方式一:

1、打开运行。

2、运行中输入 sysdm.cpl ,点击确定。

3、打开系统属性,进入【远程】-【远程桌面】,取消“仅允许运行使用网络级别身份验证的远程桌面的计算机连接(建议)(N)”,点击应用。

      如果这里是取消状态但还是闪退,就把这个设置勾上试一下,有时也会有用。

有些机器的 NLA 设置是置灰状态,无法设置,这种情况需要用第二种操作方式。

操作方式二:

1、打开运行,输入 gpedit.msc ,点击确定。

2、打开本地组策略,进入列表目录【计算机配置】-【管理模板】-【Windows组件】-【远程桌面服务】-【远程桌面会话主机】-【安全】,打开“要求使用网络级别的身份验证对远程连接的用户进行身份验证”

3、修改为“已禁用”,点击应用。

     有时候禁用也不行,需要更换为启用。

二、配置远程连接指定安全层为RDP

1、打开运行,输入 gpedit.msc ,点击确定。

2、打开本地组策略,进入列表目录【计算机配置】-【管理模板】-【Windows组件】-【远程桌面服务】-【远程桌面会话主机】-【安全】,打开“远程(RDP)连接要求使用指定的安全层”。

3、修改为“已启用”,安全层设置为“RDP”,点击应用。

三、登录后显示计算机名字段为空

问题原因:

这个只出现在 V3/V4 版本,用户使用 V2 版本的 JumpServer 客户端拉起 V3/V4 堡垒机上的 Windows 资产,会因为客户端版本不够导致 TOKEN 无法被获取。

解决方法:

在用户的电脑上卸载老版本的 JumpServer 客户端,下载并安装新版本客户端。



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