知识库

Loading

0 评论 / 0 点赞 / 176 阅读  常见问题 最后更新: 2022-09-20 作者: 飞致云 总字数: 407

1 问题描述

离线安装 DataEase 时报错:The Compose file ‘./docker-compose.yml’ is invalid becasue: services.dataease.depends_on contains an invalid type,it should be an array.

如下图所示:
image-1656062063665

2 问题分析

一般出现这个情况是因为系统在安装 dataease 之前已经安装了 docker-compose,但是版本太低,需要升级到 1.29.2。

3 解决操作

在服务器中升级 docker-compose。

指令如下:

sudo curl -L https://get.daocloud.io/docker/compose/releases/download/1.29.2/docker-compose-`uname -s`-`uname -m` > /usr/local/bin/docker-compose
文章目录
其他资源