知识库

Loading

0 评论 / 0 点赞 / 222 阅读  常见问题 最后更新: 2022-09-20 作者: 飞致云 总字数: 438

如图所示:
image-1655862782838

出现这个问题的原因是 dataease 基础依赖 dataease-extension-sdk 的版本与 dataease 的版本不一致。

dataease 代码仓库:https://github.com/dataease/dataease

dataease-extension-sdk 代码仓库:https://github.com/dataease/dataease-extension-sdk

拉取 dataease-extension-sdk 代码,切换到与 dataease 相同分支(比如 dataease 用的 dev 分支,那么 dataease-extension-sdk 也要使用 dev 分支,确保分支一致),执行 mvn clean install 将依赖安装到本地。

如图所示: dataease 分支:
image-1655862796574

dataease-extension-sdk 分支:
image-1655862801795

对 dataease-extension-sdk 执行 mvn clean install
image-1655862807443

接着 mvn -> reload project
image-1655862812868

再次编译:

image-1655862817406

编译成功。

文章目录
其他资源