应用发布机问题处理汇总


飞致云 发布于 2023-03-31 / 1927 阅读 / 0 评论 /
本文汇总 JumpServer V3 版本部署应用发布机时的 FAQ。

一、应用发布机部署时卡住

问题现象:

在 Windows 2012 / 2012 R2 / 2016 / 2019 比较早期的版本,使用 Ansible 连接有时候会任务会卡住,或者提示 ansible 'utf-8' codec can't encode characters in position 102-107: surrogates not allowed. 

解决方案:

此问题的解决方法是通过更新补丁,或者使用集成最新补丁的镜像重新部署即可。

二、获取认证信息失败

问题现象:

error

解决方案:

同步应用发布机时间。

三、Tinker 安装包获取失败

问题现象:

解决方案:

配置发布机 Core 服务地址为 JumpServer 访问地址。如下图所示。

四、终端注册问题

问题现象:

JumpServer 部署远程应用发布机时,自动化部署任务停留在 ”Wait Tinker api health“ 阶段,异常信息如下:

解决:

开启终端注册功能。在早期版本中,该操作位置位于:系统设置→安全设置→终端注册。

在 V3版本中,组件注册操作默认为开启状态。

原因:

部署远程应用过程中会新增一个终端,名称为 Thinker。当关闭终端注册时,该组件不能正常生成。

五、用户登录问题

问题现象:

JumpServer 部署远程应用发布机成功,选择远程应用连接资产时提示账号密码错误。

解决:

删除 Windows 远程应用发布机上的 JumpServer 上的账号,手动在应用发布机上创建 ”jms_“ 开头的用户,并添加到应用发布机账号列表中。新建系统后需要重启 Tinker 服务( Windows 服务器上),用以加载远程应用账户列表中的账号列表。

原因:

JumpServer 应用发布机会手动创建 100 个账户,但您的 windows 可能加域或者有较严格的密码策略,所以自动新建用户失败。

六、无法连接到远程桌面服务器问题

问题现象:

远程应用部署完成后,远程桌面 Web 页面及数据库连接时均报错”无法连接到远程桌面服务器(网络不可达|安全策略错误)“。

排查方向:

  1. JumpServer 到应用发布器的网络是否正常,应用发布机到 Web 网页或者数据库的网络是否正常;

  2. 应用发布机负载是否正常;

  3. 应用发布机中的账号是否处于激活状态;

  4. 系统设置中的终端监控中的 Tinker 终端是否正常;

  5. Web GUI 与客户端的方式连接 Windows 的方式是否正常;

  6. 使用应用发布机中的账号直接登录堡垒机是否可以正常登录;

解决:

排查发现,Windows 发布机无法通过账号列表中的账号密码登录,报错该用户没有远程权限。需要将新建的用户加入到 “Remote Desktop Users” 组中,解决以上问题。

原因:

用户没有权限使用远程功能。



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